Project

General

Profile

以下の条件でサーバのGGをバージョンアップ出来るか?

技術ノート
03/01/2011

[番号]
技術ノート KGTN 2011022503

[現象]
以下の条件でサーバのGGをバージョンアップ出来るか?

●現状 サーバ ggw-3.2.1.4420 クライアント ggw-3.2.0.4203
●希望 サーバ ggw-3.2.1.4474 クライアント ggw-3.2.0.4203

[説明]
3.2系は,サーバとクライアント間で下位互換性と上位互換性がありますので,希望の構成で利用することが出来ます.但し, ggw-3.2.0.4203 → ggw-3.2.1.4474 で修正された項目のうち,クライアントのアップデートが必要な項目は反映されません.

参 考
Ver3.2系では,クライアントとサーバは 「接続性に関して」 それぞれ後方互換性があります.従って,Ver3.2系内ではバージョンが異なるクライアントとサーバを組み合わせて利用することが可能ですが,しかし組み合わせによって修正内容が 「反映される/反映されない」 と言った機能的な問題が発生しますので,本番運用に当たっては十分な事前検証をお願いします.

2.3 Backward Compatible Client and Server (3.2系のリリースノートより)
---------------------------------------------------------------------------------------------
This allows a client to connect to a GO-Global Server when the major and minor versions of the client and server match but the service pack or build numbers do not.

Files

KGTN2011022503.pdf (68.9 KB) kitasp 技術センター, 03/01/2011 02:42 PM